Carrot2 web application

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Carrot2 web application

jelday
Dear Forum,
I am currently trying to get an instance of the Carrot2 web application running on a Tomcat server. Unfortunately, I have hit a snag.

The log contains the following line. It has been suggested that this might result from a mismatch in the JDK used during the build and that running on the server (1.6, 1.7 or 1.8)?

Caused by: java.lang.UnsupportedClassVersionError: org/carrot2/webapp/LogInitContextListener : Unsupported major.minor version 51.0 (unable to load class org.carrot2.webapp.LogInitContextListener)

Does this sound plausible and, if so, could someone advise on the JDK used during the build so I can get this adjusted on my server?

Many thanks in advamce,
Jon.

 
Reply | Threaded
Open this post in threaded view
|

Re: Carrot2 web application

Dawid Weiss
Java 1.7 is required to run Carrot2 (you probably have 1.6 on the server).

https://en.wikipedia.org/wiki/Java_class_file

Dawid

On Wed, Jun 8, 2016 at 7:57 PM, jelday <[hidden email]> wrote:

> Dear Forum,
> I am currently trying to get an instance of the Carrot2 web application
> running on a Tomcat server. Unfortunately, I have hit a snag.
>
> The log contains the following line. It has been suggested that this might
> result from a mismatch in the JDK used during the build and that running on
> the server (1.6, 1.7 or 1.8)?
>
> Caused by: java.lang.UnsupportedClassVersionError:
> org/carrot2/webapp/LogInitContextListener : Unsupported major.minor version
> 51.0 (unable to load class org.carrot2.webapp.LogInitContextListener)
>
> Does this sound plausible and, if so, could someone advise on the JDK used
> during the build so I can get this adjusted on my server?
>
> Many thanks in advamce,
> Jon.
>
>
>
>
>
> --
> View this message in context: http://carrot2-users-and-developers-forum.607571.n2.nabble.com/Carrot2-web-application-tp7578940.html
> Sent from the Carrot2 Users and Developers Forum mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> What NetFlow Analyzer can do for you? Monitors network bandwidth and traffic
> patterns at an interface-level. Reveals which users, apps, and protocols are
> consuming the most bandwidth. Provides multi-vendor support for NetFlow,
> J-Flow, sFlow and other flows. Make informed decisions using capacity
> planning reports. https://ad.doubleclick.net/ddm/clk/305295220;132659582;e
> _______________________________________________
> Carrot2-developers mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/carrot2-developers

------------------------------------------------------------------------------
What NetFlow Analyzer can do for you? Monitors network bandwidth and traffic
patterns at an interface-level. Reveals which users, apps, and protocols are
consuming the most bandwidth. Provides multi-vendor support for NetFlow,
J-Flow, sFlow and other flows. Make informed decisions using capacity
planning reports. https://ad.doubleclick.net/ddm/clk/305295220;132659582;e
_______________________________________________
Carrot2-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/carrot2-developers
Reply | Threaded
Open this post in threaded view
|

RE: Carrot2 web application

jelday

Dear Dawid,

Many thanks. Problem now solved.

 

With kind regards,

Jon.

 

From: Dawid Weiss [via Carrot2 Users and Developers Forum] [mailto:ml-node+[hidden email]]
Sent: 08 June 2016 21:33
To: Jon Day <[hidden email]>
Subject: Re: Carrot2 web application

 

Java 1.7 is required to run Carrot2 (you probably have 1.6 on the server).

https://en.wikipedia.org/wiki/Java_class_file

Dawid

On Wed, Jun 8, 2016 at 7:57 PM, jelday <[hidden email]> wrote:


> Dear Forum,
> I am currently trying to get an instance of the Carrot2 web application
> running on a Tomcat server. Unfortunately, I have hit a snag.
>
> The log contains the following line. It has been suggested that this might
> result from a mismatch in the JDK used during the build and that running on
> the server (1.6, 1.7 or 1.8)?
>
> Caused by: java.lang.UnsupportedClassVersionError:
> org/carrot2/webapp/LogInitContextListener : Unsupported major.minor version
> 51.0 (unable to load class org.carrot2.webapp.LogInitContextListener)
>
> Does this sound plausible and, if so, could someone advise on the JDK used
> during the build so I can get this adjusted on my server?
>
> Many thanks in advamce,
> Jon.
>
>
>
>
>
> --
> View this message in context: http://carrot2-users-and-developers-forum.607571.n2.nabble.com/Carrot2-web-application-tp7578940.html
> Sent from the Carrot2 Users and Developers Forum mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> What NetFlow Analyzer can do for you? Monitors network bandwidth and traffic
> patterns at an interface-level. Reveals which users, apps, and protocols are
> consuming the most bandwidth. Provides multi-vendor support for NetFlow,
> J-Flow, sFlow and other flows. Make informed decisions using capacity
> planning reports. https://ad.doubleclick.net/ddm/clk/305295220;132659582;e
> _______________________________________________
> Carrot2-developers mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/carrot2-developers


------------------------------------------------------------------------------
What NetFlow Analyzer can do for you? Monitors network bandwidth and traffic
patterns at an interface-level. Reveals which users, apps, and protocols are
consuming the most bandwidth. Provides multi-vendor support for NetFlow,
J-Flow, sFlow and other flows. Make informed decisions using capacity
planning reports. https://ad.doubleclick.net/ddm/clk/305295220;132659582;e
_______________________________________________
Carrot2-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/carrot2-developers


If you reply to this email, your message will be added to the discussion below:

http://carrot2-users-and-developers-forum.607571.n2.nabble.com/Carrot2-web-application-tp7578940p7578941.html

To unsubscribe from Carrot2 web application, click here.
NAML